Nuwan

Apache Server On Xampp Problems in starting Apache service on xampp

Recommended Posts

If XAMPP Apache won't start...

and your not running IIS...

and you're not running Skype...

 

...Continue reading. Solution below (Windows)

 

First, open C:\xampp\apache\logs\error.log and see what the error is.

 

If the error says that a port is already in use, the instructions below will explain how you can determine which application is using that port (Windows).

 

My error log entry said that Port 443 was already being used (and I wasn't running IIS or Skype)

 

(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:443

no listening sockets available, shutting down

 

To determine which application is using Port 443 (or port 80), do the following (Windows)

 

1. Open a DOS window - Start | Run | "CMD"

2. Type the following: netstat -aon

3. Find the local address using :443 (example: 127.0.0.0:443)

4. Now find the PID associated with that active connection (last column) - This is the application that's using that port.

5. To figure out what application is associated with that PID, do the following:

6. Open Task Manager (Ctrl+Alt+Del) and select the Processes tab.

 

By default, you will only see the following columns in the Process Tab:

- Image Name

- UserName

- CPU

- Mem Usage

 

7. Click View from the dropdown menu, "Select Columns...", and then place a check next to PID (Process Identifier) - you will now be able to see the PID for each

 

8. Find which application (Image Name) is associated with the PID

 

You have now identified which application is screwing up your Apache Service.

 

btw, my problem was PMB.EXE, which is Pando Media Booster. Pando Media Booster is the Peer-to-Peer downloader client for Dungeons and Dragons Online. As soon as I uninstalled it, Apache started no problem.

 

I hope that helped.

Share this post


Link to post
Share on other sites

7. Click View from the dropdown menu, "Select Columns...", and then place a check next to PID (Process Identifier) - you will now be able to see the PID for each

Wow! I even did not know that we could "select columns" and see the PID. Thanks, this was useful.Do you think this works with vista too?

Share this post


Link to post
Share on other sites

btw, my problem was PMB.EXE, which is Pando Media Booster. Pando Media Booster is the Peer-to-Peer downloader client for Dungeons and Dragons Online. As soon as I uninstalled it, Apache started no problem.

This maybe because of both of the programs requiring same ports for working. Or maybe both need resource from same services. Not sure which one they need though. Perhaps asking this questing on PMB/XAMPP will tell you about the system resources they take and that will explain why there is conflict between two.

Nice info by the way.

Share this post


Link to post
Share on other sites

I was having same problem, xampp and mysql both can not be started on my vista 32bit. I figured out that was due to not having full permission to logged user. I right click on installed xampp directory and give full permission to logged user. That solved my xampp problem.

-reply by Arshad

Share this post


Link to post
Share on other sites
Another problem trying to start ApacheApache Server On Xampp

I have the same problem; XAMPP Apache won't start.

Checked the error log and this is the message I find:

Syntax error on line 505 of E:/Program Files (x86)/xampp/apache/conf/httpd.Conf:SSLSessionCache: Invalid argument: size has to be >= 8192 bytes

So looking in httpd.Conf I see the following:

SSLSessionCache "shmcb:logs/ssl.Scache(512000)"

I change this line to:

SSLSessionCache "shmcb:logs/ssl.Scache(8192)"

Try to start apache again and get the same error message. Any ideas?

BTW No Skype or IIS running and doing a port check, port 80 is free and I'm running 64 bit Windows 7

TIA

-reply by Steve

 

Share this post


Link to post
Share on other sites
ThanksApache Server On Xampp

 Thanks.

I am googling  for this problem and found solution here " Turn Skype off "

Really Thanks You

{{sorry for my English}}

-reply by LARDI

Share this post


Link to post
Share on other sites
Unable to start Xampp.. No skype.. ports free...Apache Server On Xampp

Hi All,

 I have apache running for a while and had no trouble until lastWeekend...I tried redirecting one of my domains from my hosting to mySystem at home just to have fun..Everything worked well.. I laterRestarted my machine and then onwards my Apache does not startup.. IHave no programs like skype or any other program that might be blockingThe port 80... I tried doing the port check and all ports are displayedFree.. Port 80,81, 443 and so are free... Irepeatedly restarted myMachine but the problem wouldnt go... 

 Error Log in apachelogAccess.Log 

66.131.205.185 - - [14/Feb/2010:12:03:35 -0500] "GET/favicon.Ico HTTP/1.1" 404 1163 "-" "Mozilla/5.0 (Macintosh; U; IntelMac OS X 10.6; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7"66.131.205.185 - - [14/Feb/2010:12:03:38 -0500] "GET /favicon.IcoHTTP/1.1" 404 1163 "-" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6;En-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7"66.131.205.185 - - [14/Feb/2010:12:05:05 -0500] "GET /abx/ HTTP/1.1"200 14651 "http://bhushan.ms/; "Mozilla/5.0 (Macintosh; U; Intel Mac OSX 10.6; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7"

 

Error Login apachelogerror.Log

httpd.Exe: Syntax error on line 460 ofC:/Xampp/xampp/apache/conf/httpd.Conf: Syntax error on line 125 ofC:/Xampp/xampp/apache/conf/extra/httpd-xampp.Conf:</LocationMatch> without matching <LocationMatch> sectionHttpd.Exe: Syntax error on line 460 ofC:/Xampp/xampp/apache/conf/httpd.Conf: Syntax error on line 125 ofC:/Xampp/xampp/apache/conf/extra/httpd-xampp.Conf:</LocationMatch> without matching <LocationMatch> sectionHttpd.Exe: Syntax error on line 460 ofC:/Xampp/xampp/apache/conf/httpd.Conf: Syntax error on line 125 ofC:/Xampp/xampp/apache/conf/extra/httpd-xampp.Conf:</LocationMatch> without matching <LocationMatch> section

 

 Now from the logs I tried to go to the files httpd-xampp.Conf andHttpd.Conf but I don't understand what to do.. I tried googling aroundBut found nothing... I wouldbe glad if someone has a solution forThis...

Thanks

 Bob 

 

Share this post


Link to post
Share on other sites
IIS on Windows 7Apache Server On XamppHi. I'm getting ready to download Joomla and in reading the instructions, I need to install XAMPP installer from Apache. After reading the comments in this forum, should I turn off my IIS before installing to prevent any problems in advance? Thanks.-question by BuckeyeRobin

 

Share this post


Link to post
Share on other sites

(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted.  : make_sock: could not bind to address 0.0.0.0:80No listening sockets available, shutting downUnable to open logs

This is what I get from the log file. Please someone help me !

Share this post


Link to post
Share on other sites
apache is reported as started but it is not runningApache Server On Xampp

Replying to NuwanA also have the same problem after another installation of XAMPP, and found apache2.2 process stopped. But it is still sitting hidden. What to do?Help would be appreciated

-reply by Vitaly

Share this post


Link to post
Share on other sites
Apache Server On Xampp - Problems in starting Apache service on xamppApache Server On Xampp

When I started XAMPP control panel application, Apache and FileZilla start running normally but MySql is not running. When I click on it, MySql start running for about 1 or 2 second and stop again. No matter how much I try clicking, the same problem occur and the following message appear:Apache Service StartedBusy...Apache Service Started [port 3306]Busy...Please help me solve this problem.Thanks in advance.Jack,

-question by Jack

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now