Nuwan

Apache Server On Xampp Problems in starting Apache service on xampp

Recommended Posts

Hi... I downloaded and installed the newest version of xampp. But when i try to start the Apache service it does not get started. The MySql and FileZilla services start without any problem. But the Apache service does not start. It returns with a message saying Apache service not started [-1]. I tried by stopping the windows firewall but didn't have any luck. If there is anyone who can help me out here i would be really great full. Thanks in advance. Nuwan.

Share this post


Link to post
Share on other sites

A very likely chance is that you have IIS install, which comes standard for WinXP, and some installation of other software might have enabled it. Try to check under Services and see if IIS is running, it's name is "IIS Admin" and "World Wide Web Publishing". If so, stop the service, now you should be able to start your apache. If you want to run both concurrently, you need to change the port of either the IIS or the ApacheIf this doesn't help, or your IIS is not installed, then look under your apache folder, either together with XAMPP, or for my case it's "C:\Program Files\Apache Group\Apache2". Under the logs folder you should see and error.log file. Open that with notepad, there should be some message indicating the problem. For the IIS case, it will show you that port 80 is in used. The Error.og file is a file that you might want to look into once in a while to see if any major problem is creeping in.

Share this post


Link to post
Share on other sites

I use XAMMP also on a daily basis and the only time I have seen any installation problems is when IIS involved, follow the steps above from Lee and you shouls get sorted out.XAMMP is the easiest and best way to simulate the services we offer here on your home pc, a lot of us use it and are experts on it so feel free to tell us how you get on with it :blink:

Share this post


Link to post
Share on other sites

Hi guys... I finally got the apache service running. I checked whether i had IIS installed. But i hadn't got IIS installed. So probably it had to be some other issue. So when i went through my list of services i saw that i had a Apache2.2 service already installed, but when i checked it's path it was not the location that it should have been. It's path was set to another older location where Apcahe service was previously installed. When i try to run the Apache service it goes and looks for the older location. So i deleted the old apache service, uninstalled my current xampp and reinstalled it. Now i've got it up and running. Thank You. Regards, Nuwan

Share this post


Link to post
Share on other sites

i have xampp portable on my jump driveive never had any problem with iti love having protable stuff on my jumpdrive, it doesnt relly on anything that comes on windows!

Share this post


Link to post
Share on other sites

Also, if someone will be reading this post by searching google or also will be having similar problems, another thing which might be the problem that you have Skype installed, so if you are installing a server such an apache which requires port 80 by default, you should turn Skype off or any other software which might be using the port 80 as alternative or as primary, as I know Skype has a check-box wheaver to use port 80 as alternative or not..Moreover, it is a good advice to run software, apache in this case through a console/dos/cmd/shell/cli whatever because usually you get the error message if it wasn't successful to start the service. :blink:

Share this post


Link to post
Share on other sites

Also, if someone will be reading this post by searching google or also will be having similar problems, another thing which might be the problem that you have Skype installed, so if you are installing a server such an apache which requires port 80 by default, you should turn Skype off or any other software which might be using the port 80 as alternative or as primary, as I know Skype has a check-box wheaver to use port 80 as alternative or not..
Moreover, it is a good advice to run software, apache in this case through a console/dos/cmd/shell/cli whatever because usually you get the error message if it wasn't successful to start the service. :blink:

The alternative for skype to use port 80 is to bypass some system where they block those messaging and voip client. Generally port 80 is left untouch

Share this post


Link to post
Share on other sites

Hi...
I downloaded and installed the newest version of xampp. But when i try to start the Apache service it does not get started. The MySql and FileZilla services start without any problem. But the Apache service does not start. It returns with a message saying Apache service not started [-1].
I tried by stopping the windows firewall but didn't have any luck.
If there is anyone who can help me out here i would be really great full.

Thanks in advance.
Nuwan.


As mentioned by Quantrux and faulty.lee, the problem is because of having another software bound to port 80. Microsoft IIS is the most common troubler. Others include the lightweight, EasyPHP. You can make IIS and XAMPP Apacher work together. To do this, go to website properties in IIS and change the port number to any free port like 8080.

Share this post


Link to post
Share on other sites

im having another problem sort of to do with xampp...root@localhost doesnt have permission to do anything, which is a problem because i cant make databases or do anything with it.it ses to edit config.inc.php but yeah... wot do i edit? cos the host is localhost and the user is root.help? cos i usually try things on my computer before i upload.

Share this post


Link to post
Share on other sites

Wow faulty.Lee, man your amazing and u were totally right!

I did google search it and I was looking for hours

then u told us about skype, I turned it off and it finally worked!

I dnt know how much to thank u bro

your amazing thank so soooo much!

Share this post


Link to post
Share on other sites
Problem Installing Xampp on Vista BasicApache Server On Xampp

Hi,

 I have windows vista basic on my computer, I have the zip file downloaded and followed all the installations correctly. But still my apache doesnt remain started, Mysql is working fine. I read in the thread about trying using cmd..I dint get any syntax error, it was saying as syntax ok. I installed and uninstalled couple of times. I have no clue wat the problem is please help me ! thanks 

-reply by shrek

 

Share this post


Link to post
Share on other sites

Hi...

  You guys helped me a lot... In figuring out why my apache has not been running... Thank you very much... I should add to these conversations that if the path of the appache is not right in Sevices.Msc... Then go into the Xammp installation folder find Apache folder; in that uninstall Apache as service and reinstall Apache as service... Doing that has fixed my problem rather than uninstalling the Xampp itself... 

Any ways thank you...

-reply by Joseph

Share this post


Link to post
Share on other sites
I really appriciate ..Apache Server On Xampp

Thank you ,I really appreciate your answer ,It was the answer which  I have been looking for /txtmngr/images/smileys/smiley1.Gif

-reply by hsanatolia

Share this post


Link to post
Share on other sites
skype solved my problemApache Server On Xampp

I have Vista x64 and no IIS (as far as I know) ... Turning skype off enabled start of Apache service... Tnx guys !

-reply by klavdij

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now