bluedragon

Help ! Windows Displaying Incorrect Time .. Windows Displays incorrect time while Ubuntu works perfectly

Recommended Posts

there might be a problem with your bios,s cmos battery but i want to say you that check at first the time after two consecutive power shut down by just shutting down xp two times.because last week i had installed dual boot with xp n ubuntu,,i got every time i shut down xp n start ubuntu.i have a dell laptop n using xp sp2 32 bit.perhaps due to different architecture ,the result is coming like this.if the time gets changed automatically,,also uncheck auto synchronization of time in time box by clicking in taskbar.
if the problem persist,,try to change the cmos battery.


@ onkarnath2001 - DONT YOU READ BEFORE POSTING .. MY CMOS' BATTERY IS FINE .. I AM NOT GOING TO CHANGE IT .. PLEASE DON'T POST JUST FOR THE SAKE OF POSTING WHEN YOU DON'T KNOW WHAT IS GOING ON .. and IF YOU NEED the SOLUTION > SEE rvalkass' comment

Share this post


Link to post
Share on other sites
Ubuntu & Windows switching timeHelp ! Windows Displaying Incorrect Time ..

hey

had same issue . Ubuntu + Windows XP dual boot.

If I started Ubuntu , then next boot of Windows had wrong time (1 or 2 hours difference accordingly to timezone and legal/sun time period.

If  is tarted Windows any number of time, no change. Then next boot of Ubuntu, time is correct in there, but following Windows boot wrong again.

 

Now, fixed first time with a script in Windows which forced internet NTP synch at boot. 

 

Now have same problem, after installing Windows 7 , since looks like previous scripting not working (permission issues).

 

At the end of the day, I suppose  it's Ubuntu which stores different timing at boot then what Windows expect to find.

 

It really annoyes me too, but too lazy or busy so far to give it a shot :-))

We'll see. I might expect there's some setting in Ubuntu to be changed .. And eventually workaround again with scripting in Windows.

 

Bye

 

-reply by Offcourse

Share this post


Link to post
Share on other sites
Make change in UbuntuHelp ! Windows Displaying Incorrect Time ..

As mentioned by others the problem is in the different ways that Linux and Windows look at the system clock.

You can try a registry setting in Windows: HKLM > System Current Control Set > Control > TimeZoneInformation

If there is not a DWORD for RootTimeUniversal creat one and set it to 1

This may or may not work.

Better to make the change in Ubuntu open a text editor such as gedit as administrator (e.G. In Terminal use command "sudo gedit" and you'll be prompted for your password. Then find file reS in folders etc > default

It's a small file so you'll have no trouble finding the line which is:

UTC=yes

and change it to

UTC=no

It did take me quite a while to find this after lots of misleading info in many places on the internet, such as all the advice about CMOS batteries. Sure if they're faulty they lead to time errors, but not consistent ones that are in line with the world's time zones.

 

-reply by Gordon Woolf

Share this post


Link to post
Share on other sites

The main problem can be in your motherboard. Test the CMOS battery. Because CMOS(Complementary Metal Oxide Semiconductor) battery stores the information about the dates. So if the CMOS batter is old it can create problem in date setting. So check for CMOS battery first. and then go for other checking such as control panel settings and all.

Share this post


Link to post
Share on other sites

The main problem can be in your motherboard. Test the CMOS battery. Because CMOS(Complementary Metal Oxide Semiconductor) battery stores the information about the dates. So if the CMOS batter is old it can create problem in date setting. So check for CMOS battery first. and then go for other checking such as control panel settings and all.



He mentioned in his very first post that its not the cmos battery....

Iam sure its the os... Try formating and booting up with 1 Os....

Share this post


Link to post
Share on other sites

I have no problem with time with Fedora core 5, Ubuntu and Windows XP on my computer before. I set Fedora to pick the timezone from Taiwan, set Ubuntu to pick time from Taiwan and set Windows time sync to Taipei. Basically I am from Philippines and my timezone is +8 Manila. We don't have Daily Time Savings but the other zones on my timezone does.

 

The root of the problem was Ubuntu and Fedora can give you an exact timezone up to city level and have more time tables, technically Linux/Unix time is correct but Windows was not. Windows for some reason thinks that a timezone of +8 Manila does not belong to timezone + 8 instead it puts me to timezone +4 or timezone -6 which are both wrong. Since Windows have a time table for Taipei and Australia, I can use them and tell Linux/Unix to use the same city as base timezone.

 

This does not come with a price since all my bash upgrade commands will start checking Taipei servers before it checks my local real zone to get the downloads.

 

It is windows at fault and not Linux/Unix (Ubuntu on your part). To confirm to this problem rooting from windows, I installed Mac OS on the same computer on a third hard drive and the timezone did not change when I boot from Ubuntu, Fedora Core 5 and Mac OS however without manually changing the timezone table to what locations that windows ONLY recognize, the time goes wrong.

 

In order words, all the Operating System I have tried knows how to read the time and gives more precise time zone but Windows will only follow it's own rule. Another one of 'Microsoft Only' standard.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now